PHP更新到7.3

刚建站时一直用的PHP5.6的版本,一直以来也是用这个更新,某次逛网站看到说PHP7的性能比PHP5要高大概50%,CPU占用也更少(虽然EC2的负载永远小于1%),还是忍不住想要更新过来,毕竟只有一个长期保持更新的系统才是可以维护的,虽然没有打算把系统更换到AMI2,更新下基础软件是无妨的。

找了一圈网站,介绍更新的都把Apache的更新也入在内容里,不过仔细看了下我的Apache版本已经是2.4了。重新配置Apache就有点烦了,因为。。已经不记得有改过些什么Apache的配置了,肯定是改过,然而没有记得了。

先登录AWS,创建了个更新前的快照,即使有错误操作的地方,从快照恢复也还是方便的。(快照说是按增量备份的,不过界面中看不出来,先保持原来的快照了,看下一个月的账单就知道了)

然后参照找到网站的说明

https://fizzbuzzer.com/upgrading-php7-amazon-linux-ec2-instance/

先停止apache,删除掉之前的PHP5.6

$ sudo service httpd stop
$ sudo yum remove php*  
$ sudo yum install php70 php70-mysqlnd php70-imap php70-pecl-memcache php70-pecl-apcu php70-gd  

最后

 $ sudo service httpd restart

就结束了。

和预想中一样,基本看不出什么变化。。。而且Crayon Syntax Highlighter这个插件在Gutenberg下坏了。

2019/05/11
WordPress的自检提示缺少imagick插件 ,但是三番五次安装不上,查了下deposit库才发现Linux AMI只支持到PHP7.2的imagick插件 ,并没有7.3.然而短期内並沒有計畫升級到Linux AMI 2,這兩年安裝的東西連自己都沒什麼印象了,雖然是大概並沒有裝什麼其他有用的東西,以及改過哪些程序的配置,至少也得花上一兩天時間.

然後,本來也有計畫升級到Mysql5.7,升級到5.6這一步就失敗了,不斷地提示service start 失敗.本只留了一個Snapshot,也確實不想弄半天失敗了再從Snapshot啟動.

來回折騰幾次失敗以後終於還是remove掉,重新裝回了5.5,哪天更新到Linux AMI 2的時候直接轉成MariaDB罷.

同時再過一陣時間三年期的T2.nano就要過期了,也要先轉成T3了.


后记,停用了TinyMCE Advanced,因为好像有点影响编辑时的载入速度.

Category: Personal
You can follow any responses to this entry through the RSS 2.0 feed. You can leave a response, or trackback from your own site.

发表评论

电子邮件地址不会被公开。 必填项已用*标注

此站点使用Akismet来减少垃圾评论。了解我们如何处理您的评论数据